iPhone 3G unlock now available for download

Just as promised, the iPhone dev-team’s soft unlock solution for the iPhone 3G has finally been delivered. It’s still in beta, version 0.9 to be specific, but it’s been proven to work on all iPhones with the latest baseband (02.28.00) and firmware 2.2.

The iPhone 3G soft unlock app is called yellowsn0w, and it’s available for download from Cydia, so a jailbreak is required before any of the unlocking can be done. Now you can easily activate, jailbreak, and unlock your iPhone 3G. There are just a few things the dev-team would like to remind you.



Quoting from their latest updates regarding yellowsn0w:

– The unlock works exclusively with baseband 02.28.00. This baseband is provided by the latest firmware update (2.2) from Apple. You’ll need to upgrade to this release using iTunes and then use QuickPwn to activate etc. There are plenty of tutorials about this on iclarified, bigboss, and other established tutorial sites. Because it works on 02.28.00, it is available to everyone on the planet. This means we don’t need to unnecessarily expose holes in earlier basebands, which is an important concern.

– There is a known issue with SIM cards that have STK (SIM Toolkit) application menus. These menus are usually items such as “top up” “get credit” “lotto numbers” etc. These menu items confuse the application sometimes. Removing and reinserting the SIM once after reboot (give it about 10 secs 60 seconds (with v0.9.1) after you see the slide to unlock widget) fixes this issue. We’re working on a better fix.

– If you are in the U.S. and are trying this with T-Mobile, you must turn off the 3G switch in Settings. Also if you are good with the command line, you can make it much easier by adding the line -q right after the /usr/bin/yellowsn0w line in /System/Library/LaunchDaemons/org.iphone-dev.yellowsn0w.plist (that’s and advanced tip, hopefully someone will make a boosprefs type of tool for it)

– No PIN support yet. Remember how we said this was beta? Well we’re still working out the flow for SIMs with PINs enabled. Please disable any PIN you may have on that SIM before trying yellowsn0w, for now.

– The unlock will silently quit on anything other than baseband 02.28.00. It detects the wrong version and just quits to avoid any damage. Please double check your Modem Firmware setting in Settings->General->About.

– The application is released on a non-commerical basis. Please do not accept pirates and scummy ripoffs of this software. We license this software for single use and in a non-commerical environment (meaning you can’t charge for it). The techniques and methods used are not to be used by third party companies. We are watching you Jody…we won’t be so forgiving this time.

The Cydia resource link: http://apt9.yellowsn0w.com/
The Installer repo: http://i.yellowsn0w.com/

Good luck, and enjoy unlocking the iPhone 3G you’ve got there.

UPDATE: Many users are reporting that the yellowsn0w iPhone 3G unlock released by the dev-team a day ago hasn’t worked for them. The installation seemed to be a cinch, but actually making the hack work to unlock their iPhone 3Gs was the hard part. It worked for others, but a number of individuals still remain unsuccessful with their unlock attempts. Perhaps we’ll learn more about why this is so later in the day.

Via Dev-Team Blog

Author: David Gonzales

I run the blogosphere.

Share This Post On
  • dev

    “but it’s been proven to work on all iPhones with the latest baseband (02.28.00) and firmware 2.2.”

    Total bs… pls dont spread misinformation.

  • http://www.yellowsn0w.net yellowsn0w

    It works on baseband 02.28 only!

  • Misunderstood

    It does work Im runnin my phone on tmobile in the us with no more turbosim and thanks to dev teams efforts!!! And yes it is only for 02.28.00 tried it wit 2.11.07 and didn't work so u have to upgrade your baseband..

  • Misunderstood

    It does work Im runnin my phone on tmobile in the us with no more turbosim and thanks to dev teams efforts!!! And yes it is only for 02.28.00 tried it wit 2.11.07 and didn't work so u have to upgrade your baseband..