iOS 5.0 won’t work on iPhone 3GS?

With Apple’s WWDC conference coming in June, we can expect to find out more about iCloud, OSX Lion, and the new iOS 5. Of course we hear plenty of rumors in the upcoming weeks leading to the conference.

The latest rumor was said by analyst and Mobile-Review.com editor, Eldar Murtazin. He wrote the following comment on his twitter page: “Just one comment. Apple iPhone 3Gs wont be upgradable to iOS 5.x. iPhone 4 will.” Although there is no hard evidence to support his claim, he has been right in the past about the Nokia N8 and the Nokia/Microsoft deal.

According to other rumors, Apple has been testing out iOS 5.0 on the iPhone 3GS and the 3rd gen iPod Touch, but they may have decided that it doesn’t run well enough on devices from 2009. Apple has been consistent with leaving other devices in the dark such as the original iPhone with iOS 4.0 in the summer of 2010 and with the iPod Touch 2nd gen and iPhone 3G with iOS 4.3 earlier this year. We will keep you updated on the rumors preceding WWDC.

Twitter

Author: Dakota Torres

Share This Post On